A-A+

关于WordPress论坛插件:Ucenter的"通信失败"的终极解决办法,2018年实操经验分享

2018年12月15日 WEB技术 暂无评论 阅读 524 次

Ucenter插件是一款不错的WP整合论坛功能的插件,让wordpress站点的用户数据能很好的与Discuz论坛程序互通,是大家最喜欢的一款的插件.只是这个插件的最近更新时间却是在 7年前,可以说算是古董级别的插件了,年久失修,这不,我用上之后,就出现问题了,无论怎么整,DiscuzX的后台都显示"通信失败".

Ucenter 通信失败

整了很久很久,发现怎么都不行,最后发现是与php(V5.6.36)的版本有关系.wordpress的配置文件开始BUG检测功能之后,一直提示插件的主文件报错,有多行报错.

细查之下,发现是这个插件的php的方法写法上面与我使用的PHP版本不兼容,如是,批量修改之后,问题就解决了,那个地方终于显示正常了,出现了久违的"通信成功":

那个地方终于显示正常了,出现了久违的"通信成功":

我的wordprss版本:4.9.9 :

我的wordprss版本:4.9.9

 

我的DiscuzX版本:3.2 UTF-8:

我的DiscuzX版本:3.2 UTF-8

 

 

wordprsss后台的用户相关的设置项:

后台积分相关的选项

 

两个程序互通的用户帐户:

两个程序互通的用户帐户

 

 

此插件已完全改良,适用于最新版的Wordpress4.99程序,需要的WP友可以联系本人.

给我留言

icon_question icon_razz icon_sad icon_evil icon_exclaim icon_smile icon_redface icon_biggrin icon_surprised icon_eek icon_confused icon_cool icon_lol icon_mad icon_twisted icon_rolleyes icon_wink icon_idea icon_arrow icon_neutral icon_cry icon_mrgreen